Ozgur's Blog

Random ramblings of personal nature

Cisco Routerlarda Routing İşlemleri


Giriş

Bacakları (interface) farklı ağlara bakan routerları birbirine bağlamak için üç metod kullanılabilir:

  1. Statik Rotalama - Static Routing
  2. RIP Rotalama - RIP Routing
  3. OSPF Rotalama - OSPF Routing

Bu yazıda bu üç yöntemden bahsedilecektir.

Statik Rotalama

17

Bu rotalama türünde elle routerların bacaklarındaki ağların ne olduğu tanıtılır. Elle tanıtılması ve sabit olması yüzünden küçük ağlarda yapılması daha uygundur.

Burada köprülerken kullanılan blok:

R1> enable
R1# conf t
R1(config) ip route 192.168.2.0 255.255.255.0 10.0.0.2 # writing this is R1, 192.168.1.0 - 10.0.0.1

Şeklindedir. Burada R1 routerının üzerinde OLMAYAN networkler yazılır. Yani R1'e denilir ki

192.168.2.0 networküne çıkarken 10.0.0.2 çıkışını şu subnet mask ile kullanacaksın.

Bu komuda karşılık olarak R2 routerında şu komut yazılacaktır

R2(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1

Tüm akış şu şekilde yazılabilir:

01 - Uç Cihazlara (End Devices) IP adresleri ver

02 - Routerların İç IP Adreslerini ver

enable
configure terminal
interface gigabitEthernet 0/0/0
ip address 192.168.1.1 255.255.255.0
no sh

03 - Routerların Seri portla bağlanan kendi aralarındaki adreslerini ver

enable
configure terminal
interface Serial 0/0/0
ip address 10.0.0.1 255.255.255.0
no sh

04 - İki seri portu birbirine köprüle

R1:

enable
configure terminal
ip route 192.168.2.0 255.255.255.0 10.0.0.2

R2:

enable
configure terminal
ip route 192.168.1.0 255.255.255.0 10.0.0.1

RIP Rotalama

RIP rotalamada ise statik rotalamada yaptığımızın tersine routerda hangi networklerin bulunduğunu yazarız. Bu bilgiler diğer routerlara otomatik olarak iletilir. Uç cihazlara ve routerlara ip adreslerimizi verdikten sonra routerlarımızı RIPlemek için şu yönergeleri takip edebiliriz:

R1

enable
conf t
router rip
version 2
no auto-summary
network 20.0.0.0  # R1's Intranet
network 10.0.0.0  # R1's router network
passive-interface gigabitEthernet 0/1  # Do not send intranet multicasts to other interface

R2

enable
conf t
router rip
version 2
no auto-summary
network 30.0.0.0  # R2's Intranet
network 10.0.0.0  # R2's router network
passive-interface gigabitEthernet 0/1  # Do not send intranet multicasts to other interface

OSPF Rotalama

16 OSPF Rotalama ise RIP'e benzemekle beraber çok daha hızlı ve güvenli olması nedeniyle tercih edilmektedir. RIP'e benzer bir biçimde burada da router'ın interfacelarını yazarız ve geri kalanı routerlara bırakırız. Uç cihazlara ve routerlara ip adreslerimizi verdikten sonra routerlarımızın birbirlerine OSPF metodu ile kendi networklerini tanıtmaları için şu yönergeleri takip edebiliriz:

enable
configure terminal
router ospf 1  # config-router
network 192.168.1.0 0.0.0.255 area 0  # internal network
network 10.0.0.0 0.0.0.255 area 0  # outside network